4Dimensions Forum

General Category => Suggestions & Ideas => Once's Board => Topic started by: Once on September 13, 2011, 03:06:38 pm

Title: 09/13/2011
Post by: Once on September 13, 2011, 03:06:38 pm
Teleport fix is done. It looks like noteleport hasn't worked properly for a while now.

I'm currently told there's a problem with mining though. Can someone (Jaros or Xeriuth I'm looking at you) please shed some light here?
Title: Re: 09/13/2011
Post by: Xeriuth on September 13, 2011, 03:19:36 pm
Sure the mines are buggy, but mining/tunneling works, however the mines are inaccessible because the entrances are gone. Maybe they are gone due to a bug, but I think they could just be olc'd back in, and then it's fixed. Other than that, focus should probably go elsewhere for the time being as mining fixes are mostly cosmetic and nuisances.
Title: Re: 09/13/2011
Post by: Molly on September 13, 2011, 03:55:48 pm
As far as I know you are supposed to be able to start mining from every room that has any of the words mine, sand, soil, earth, rock, cliff (and perhaps some more) in the Room name. That was part of the original code, so it cannot have been OLCed away.

Apart from that there are some 'entrances' in the form of already existing mines in the game, for instance the Gold Mine and Sutter Mines in Oldwest, the Plastionium mine in Planet Whotvar, the mines of Thasos and Nisyrus in the Aegean islands and probably a couple more. To my knowledge all those still exist and are open. But they were mostly put into the zones for persistancy and local colour, and you shouldn't have to start from any of them to start tunnelling.

My guess is that the code is broken in reference to the above mentioned words in the Room name.
Title: Re: 09/13/2011
Post by: Xeriuth on September 13, 2011, 05:47:23 pm
That was just the only way in always. As long as I've ever mined we could never start tunneling in the gold mine. maybe the rooms have flags of those types which allow it? I've tried to start tunneling in Whotvar, haven't tried Thasos/Nisyrus or the Sutter Mines but I dont think we can tunnel into the main mines from them. There was always only two entrances on in one room and one in the room north of that room. The entrances closed up and now there is no entrance. With a quick OLC fix, they would be accessible. Without having to dive into a ton of code that doesn't really affect many people as is. Since tunneling does work, but I think it is low priority in relation to other things that need fixed. OLC = 2 minutes. Coding solution = days perhaps.
Title: Mining Bug
Post by: Once on September 13, 2011, 07:31:34 pm
So then you're saying something changed with those rooms recently? Can you give us specific room names, to make it easier for whichever builder looks into it?
Title: Re: 09/13/2011
Post by: Xeriuth on September 13, 2011, 09:02:13 pm
Yes, I'm uncertain what could've happened. The entrances to the mine or room exits in these two rooms vanished leading down. I am uncertain to what rooms they led to exactly, just that they led to a room in the loose sand layer of the mine. Simply pick a loose sand room at random and connect the room to it, but not a connection leading back up. Just down into the mine is needed. Really only one of the two rooms would need an entrance, but there used to be two for variety I guess. The two rooms that had exits leading into the loose sand layer are vnums as follows: 1417 and 1420
Title: Re: 09/13/2011
Post by: Molly on September 14, 2011, 01:48:25 am
I still think this is some code issue, and I still think that the original code made it possible to start mining from any room with the keywords I mentioned before.

There is a MINE flag in OLC, that you can set on rooms, and with that flag, the room becomes possible to tunnel from.

All the rooms in the big mine have that flag set, and possibly the rooms you mentioned used to have them too.
But neither of the zones you mention have been touched for the last 4 years, so why would the flags suddenly disappear?

The options in the menu look like this:
J) Mine         : Num: 0 Level: 1 Tool: Shovel

When a room is not possible to mine from, the first value is set as -1, which is also the default setting.
J) Mine         : Num: -1 Level: -1 Tool: None

I remember in the past when rooms that were not supposed to be mined from had that the first value set as 0 instead of -1, (which is an understandable mistake from an inexperienced builder).
It was very irritating, so it had to be fixed, and it was a pain in the ass to go through all those room manually. and guess who had to do the job?

I guess I'm the one that is supposed to add the mine flags to all the entrances that somehow mysteriously disappered too.
And this is the first time I've heard that OLC is quicker than code.
Sure, 2 minutes for two rooms you mentioned, I think that I've already fixed those.
But definitely a lot more more to decide which other rooms should have the flag.

And that still leaves the open questions: Why did the flags, that obviously existed before, suddenly disappear from several rooms in totally unrelated zones that nobody has touched for years?
Forgive me for being a bit testy, I just want to know, so it doesn't happen again after 2 years.

Title: Re: 09/13/2011
Post by: Jaros on September 14, 2011, 01:51:42 am
Maybe mining from other rooms never worked.  I know when I was into it I always entered through the rooms Xeriuth's talking about and I can vouch for the links being gone now.
Title: Re: 09/13/2011
Post by: Molly on September 14, 2011, 08:35:20 am
I've added entrances down to the main Mine from the two rooms in the Gold Mine that Xeriut mentioned.

I might add other entrances from other existing mines later, but since there are several of those spread over the world, it means a lot of more work tracking down the best room for an entrance. And I still think there's something wrong with the code.

At least for now you can enter the mine.

Title: Re: 09/13/2011
Post by: Xeriuth on September 14, 2011, 09:47:22 am
Cheers, now people can go mine. (If they want to)